ForceField Subs (65 topics)

arrow_downward
saluzulfi's Avatar
Hello everyone. I am using a forcefield 5 sub, and recently I have noticed a degradation in performance. The Sub seems to produce unpleasant rattling...
Moderator's Avatar
I have a ForceField 3 connected to a set of Vanatoo Transparent Zeros using an LFE cable. It's for my computer desktop setup. When I turn on the PC...
Redrum's Avatar
Hi; I have Triton 2's at home, got them close to when they were released, and have been happy. But, my question... I bought a FF3 for a small...
rorcocobun's Avatar
Hello, I am looking at changing the power cord on my ForceField 4 subwoofer with a 1' (or even 6") power cord as the bulk of the provided power cord...
Moderator's Avatar
Was looking on the subwoofer part of the website, see that the forcefield 5 in not available. Is it being discontinued? Or replaced?
NLkraken's Avatar
Hi All Looking for some advice on an issue I have with my ForceField 3. When listening to movies that are heavy on the LFE, my sub will sometimes...
rorcocobun's Avatar
Hello, I'm curious as to whether or not GoldenEar has any plans on updating its subwoofer adjustment methodology? Specifically, I'm wondering if...
NLkraken's Avatar
It seems I am no longer able to tighten the feet properly on my ForceField 3. The bolts have become loose inside one or two of the feet. I'm...
rjohn79395's Avatar
I have recently upgraded my system with the exception of my GE speakers. I have the SS3's L/C/R, surrounds and one (1) FF4 Sub. Even though the FF4...
Moderator's Avatar
Amp went out a while ago. Flashing green light. No Sound. Posted here and the moderator suggested I talk to my vendor to get a replacement despite...
Roman Johnston's Avatar
FF 3 unit has no output. If I un-plug and put right back in green light stays out. Unplug for about a min or more then plug in. Green light blinks...
TanLeng's Avatar
I purchased two FF5 from A&L Malaysia, both of them having the random hum with or without AV source input, it has been working fine for past 1 year...
TanLeng's Avatar
Greetings from Malaysia, A few months ago my FF5 started developing a constant low rumble, much like an aeroplane, with the occasional louder popping...
khthen's Avatar
Hello, I am from Malaysia and I have the Goldenear Forcefield 3 Subwoofer (Driven by my Marantz SR 5008 AV Receiver) for last 3 years. Recently it...
rjohn79395's Avatar
Hello, I have a dual ForceField 4 setup and after running a low frequency sweep the -3db point is at 35Hz for some reason. I know from independent...
Moderator's Avatar
hi, i purchased a used sub off craigslist and when i finally got around to checking it out it didn't work. I get the power light to come on but...
Moderator's Avatar
Hey everyone. I have owned this sub since 2011-2012, plus other Golden Ear speakers. I've been a huge fan since day one. In the last year, I can't...
Moderator's Avatar
I've recently developed some FF5 issues. The sub will continue with a low rumbling hum, with nothing being played from the source. There are also...
Moderator's Avatar
My Forcefield 3 has an audible high pressure leak coming out of the lower right binding post that no amount of electrical tape can seal so should I...
WayneWilmeth's Avatar
Hey, I'm curious as to whether or not anyone has experience with the SoundPath Subwoofer Isolation System and the Auralex SubDude-HT isolation pad....
arrow_upward
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Support ForceField Subs