file My Forcefield no longer produces any sound

  • dgrant's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 9
    • Thank you received: 6
  • arrow_drop_downMore arrow_drop_upLess
dgrant Posted 6 years 3 months ago
#4889
My forcefield 3 no longer produces any sound, but the green light is on. This unit had its electronics relaxed about a year ago for a different reason (it was producing noise, even with nothing coming in on input). Anything I might be missing? My dealer had changed management/ownership. Do I have to go back there or can I do an RMA with Golden Ear directly?

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 3020
    • Thank you received: 3337
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 6 years 3 months ago
#4890
Sorry to hear that, very strange. The ForceField 5 has been one of our most dependable products, two failures for the same person is beyond unlikely. You will need to take the unit to your selling dealer or return the entire unit to us for service. Obviously the first choice is a much better one. Once verified by the dealer we will provide service parts, you should only be without it for a few days.

Please Log in or Create an account to join the conversation.

  • dgrant's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 9
    • Thank you received: 6
  • arrow_drop_downMore arrow_drop_upLess
dgrant Posted 6 years 3 months ago
#4902
Just wondering, is the dealer compensated in any way for handling the warranty repair/replacement and dealing with Golden Ear? I've already taken it back twice, once for missing threaded hole on bottom and again for the noise problem. They have never charged me. Just curious how it works. Especially since the store is under new management/ownership. I don't know the new owners at all.

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Support ForceField Subs My Forcefield no longer produces any sound