file forcefield 3

  • bud914's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 1
    • Thank you received: 1
  • arrow_drop_downMore arrow_drop_upLess
bud914 Posted 1 year 2 months ago
#24650
hi, i purchased a used sub off craigslist and when i finally got around to checking it out it didn't work. I get the power light to come on but absolutely no sound. Any ideas??
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 4581
    • Thank you received: 7020
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 1 year 2 months ago
#24653
Hey Bud,
Sorry for you.
I have an idea, but you do not want to hear it and it would sound insensitive.

Hope you find out it is something simple and get it playing.
God Bless,
Wayne
God bless the child that's got his own.

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 2812
    • Thank you received: 3192
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 year 2 months ago
#24654
Probably needs the amp replaced. GoldenEar has a service exchange program where you can trade in the failed amp for a replacement. Cost is $99 in the U.S. If you want to do the service yourself, that's all it would cost, otherwise you can take it to a local GoldenEar dealer and they will repair for you.
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Support ForceField Subs forcefield 3