file Setting recommendations-Triton 2+s and Supercenter XXL

  • ArtVandalay7's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 5
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
ArtVandalay7 Posted 4 weeks 14 hours ago
#25702
Hello...
I wanted to get some opinions/setup tips for my current system after doing a lot of experimenting myself. My system includes:

Triton 2+ towers - mains
Supercenter XXL - center
Infinity Beta ES250 - R and L rear surrounds
Micca M8S - front Atmos speakers
SVS PB10-NSD sub - R rear corner subwoofer
Marantz SR-6012 receiver

Just looking for some input as to recommended settings. I use the system mainly for 2 channel music playback, watching movies,, and also surround music playback. I currently have the Triton towers set to large & everything else set to small. Subwoofer is set to “2 speakers”. Crossovers:: 60hz front, 80hz center, 120hz for surrounds and front heights. Bass set “LFE+Main”, 120hz.

Thoughts, any tweaking anyone would recommend? Thanks for any input!

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Administrator
  • Administrator
    • Posts: 2610
    • Thank you received: 3090
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 4 weeks 13 hours ago
#25703
All good except not LFE + Main, should be LFE only.

Please Log in or Create an account to join the conversation.

  • ArtVandalay7's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 5
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
ArtVandalay7 Posted 1 week 5 days ago
Last edit: 1 week 5 days ago by ArtVandalay7. info_outline
#25829
Thanks for the reply...my only question is that, with fronts set to large and bass set to LFE only...2 channel music sounds anemic without any bass (since I have LFE signal split between my Tritons via the LFE inputs and my standalone subwoofer). Only when LFE+Main is enabled do i get any bass on 2 channel music with the Tritons set to large...Sorry but I must be missing something...

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Administrator
  • Administrator
    • Posts: 2610
    • Thank you received: 3090
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 week 5 days ago
Last edit: 1 week 5 days ago by Moderator. info_outline
#25830

ArtVandalay7 wrote: Thanks for the reply...my only question is that, with fronts set to large and bass set to LFE only...2 channel music sounds anemic without any bass (since I have LFE signal split between my Tritons via the LFE inputs) and my standalone subwoofer.


The Triton Twos would NEVER sound anemic if properly setup, they have loads of bass for music playback. Unless there is something about your room/listening location that is causing a severe bass suckout, you need to go back and review all the settings on your receiver for speaker setup and audio playback.

Please Log in or Create an account to join the conversation.

  • ArtVandalay7's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 5
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
ArtVandalay7 Posted 1 week 5 days ago
#25831
Right, I am not faulting the speakers; I know what they are capable of but something seems off...I used Audyssey-maybe that’s the issue—especially since to calibrate the subs in the Tritons it indicated the LFE source signal was too high unless I had both towers sub level set all the way down to minimum (and even then it indicated they were still borderline too high...)

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Administrator
  • Administrator
    • Posts: 2610
    • Thank you received: 3090
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 week 5 days ago
#25832
Ah yes, turn that off, set Triton subs' gain to 12 o'clock and do some listening to stereo music. When that sounds right you can begin to experiment with other setups and have a good basis for sonic comparison. If you really need to run Audyssey, do it with just your outboard subs connected, NOT with the Tritons' LFE inputs connected (and set to Large of course). Then you can plug the Tritons' LFE cables back in and do some listening and tweaking. Probably will need to turn down LFE level on the receiver and increase the level on your outboard subs o get everything happy for movie playback. All of that should have no effect on 2ch stereo music playback.

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Getting Started Basic Hookup and Wiring Questions Setting recommendations-Triton 2+s and Supercenter XXL