file Love My Triton 3s

  • Tsgt2007's Avatar Offline
  • Senior Boarder
  • Senior Boarder
    • Posts: 73
    • Thank you received: 160
  • arrow_drop_downMore arrow_drop_upLess
Tsgt2007 Posted 4 years 6 months ago
#9123
Thank you Wayne and your welcome! Good to hear from you!
Jose
The following user(s) said Thank You: WayneWilmeth, T Cobe

Please Log in or Create an account to join the conversation.

  • T Cobe's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 2294
    • Thank you received: 4367
    • Karma: 5
  • arrow_drop_downMore arrow_drop_upLess
T Cobe Posted 4 years 6 months ago
#9131
Tsgt2007,

Thank you very much for the update! It's always nice to close the loop on these discussions and get first hand feedback. Did you check how your sound was effected with just the AudioQuest power cables? I'm still interested in upgrading my cables as well. I just upgraded my system with an Emotiva XPA-5 and the difference in both treble and bass has been significant. My next upgrade will be two mono block amps for my front main L/R speakers. When I make that upgrade, it will probably be time to look into better cables and interconnects. Thanks again for your feedback. Happy listening!

Cheers,

T Cobe
Speakers: Triton One L/R, SCXL, Aon 3 Surr/Back, HTR-7000 Height
Pre/Pro/AVR: Anthem AVM 60, Emotiva XSP-1
Amps: Emotiva XPA-5(2), Emotiva XPA-1L (2)
Sources: Oppo BDP-103D, Emotiva ERC-3, PS4, Pioneer PLX-1000 w/Ortofon 2M Bronze
Display: Epson 6030 UB, Elite Screens 110" Sable
The following user(s) said Thank You: WayneWilmeth, Tsgt2007

Please Log in or Create an account to join the conversation.

  • Tsgt2007's Avatar Offline
  • Senior Boarder
  • Senior Boarder
    • Posts: 73
    • Thank you received: 160
  • arrow_drop_downMore arrow_drop_upLess
Tsgt2007 Posted 4 years 6 months ago
Last edit: 4 years 6 months ago by Tsgt2007. info_outline
#9161
T COBE
Your very welcome! I did hear a difference with the new cables. No doubt about it! I am very happy with the T-3's. The system you have now sound like a great one to have and I could only imagine the T-3 sound amazing!

Jose
Jose
The following user(s) said Thank You: T Cobe

Please Log in or Create an account to join the conversation.

  • rjohn79395's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 1992
    • Thank you received: 3968
    • Karma: 2
  • arrow_drop_downMore arrow_drop_upLess
rjohn79395 Posted 4 years 6 months ago
Last edit: 4 years 6 months ago by rjohn79395. Reason: data correction info_outline
#9167

Dilettante wrote: Anthem and I have talked many times about power cords. He asked me to butt in here and tell you guys my story - so here goes - howbeit a shortened version.

I have an OPPO 103 feeding a Decware Torii MKIV 25 watt tube amp which drives my two T1's. I have tried everything I know to get a really "great" sound out of it. While I had "quality" sound I was confident my system could put out "extraordinary" sound. For 6 months now, I have swapped tubes, switched speaker wires, interconnects wires, and tried several high powered (read advertising) power cords. To be frank with everyone, while I heard minor differences with each of these items, I was less than impressed!! I spend upwards of 2-3 thousand dollars on these add-ons and months changing it all up to see if some combination could seriously improve the sound - all for VERY LITTLE improvement IMHO. Then one day Anthem suggested I try out the Shunyata Research Venom 3's. I found a deal on a set of 3 (MusicDirect). When they arrived, for starters, I used one to power the Torii amp - and hey I could notice a difference - significant but not overwhelmingly so. After listening for a while, turned the system off, unplugged the T1's (which we driven via Emotiva power cords as they were better than the GoldenEar standard shipped cords) and plugged them into the other two V3's. I turned the system on - and WOW!! Was I amazed!! It was overwhelming! The system had so much clarity - any orchestra seemed to have twice as many instruments - all voices had crystal clear like I had never heard except in VERY high end speakers - and each voice seemed to be upfront on the stage and sung directly into the microphone - guitar string picks were as clean and VERY musical. I could go on and on about the system - but I have to tell you, my system I would now far surpasses my expectations (and I had GREAT expectations)!!! I had a friend walk in the house last week when the system was playing - let's just say he was balled over!

I can't logically explain it! I told Anthem I didn't know if one minute all my hard work and hundreds of hours of break-in finally all hit at one time - or if these power cords just struck a "chord" with MY system. But I am saying - if you have T1s and have not tried the V3's, you owe it to yourself to try them - as someone said Music Direct has a 60 day free return policy. I don't know how they work on the T3's (this thread is about the T3's) or any other Triton speaker system - or on any other amp except the tube SET amp I am using - but I know what I have been trying to do for some 6 months - and finally I hit the jackpot when I plugged the V3's (direct from a normal household outlet) into the T1's!!!

Grace to all of you as we pursue our musical interest!!


Hi Dilettante and Anthem

Thanks for weighing in! I have T1's as fronts, T2's as surrounds, SXCL, Invisa 525 ceiling speakers. I am in the North for the summer, away from my beloved Triton Cinema system, listening to Harmon Kardon soundbars and Bose Wave systems, and so sorely missing the clarity, presence, punch, fullness, etc. etc. of the system I left behind. What a change from having lived with a DENON/Bose 901 system for many year without changing a thing.. now I so want to maximize the gorgeous sound I get from the Goldenear speakers!

I want to try the Venom 3's with my T1's when I get back in Sept.. I will order a 3 pack. What other piece of equipment would you suggest I use the 3rd power cord for (NAD AVR?, NAD amp for front T1's?)? If I like what I hear, I will get them for other stuff, like the surround T2's, CD player, DVD.

As the Moderator frequently says "it's not just the speakers". BUT it sure helps to start with great speakers!

A separate question for all FORUM members: I'm thinking of switching out from the NAD 7.1 T757 AVR to a Marantz 9.2/11.2 SR7009, to use one set of currently disconnected INVISA 525 ceiling speakers as a height/ATMOS channel. Thoughts on sound quality, user friendliness, etc. of the Marantz SR 7009? Also, it has the top of the line AUDYSSEY EQ EX T32 system, which gets good reviews (I have a room with lots of hard surfaces). Any experiences using it with Triton Cinema systems? I know The GEt setup recommendation is to NOT use room EQ, but given my room dynamics, I'm wondering..

What a great FORUM, with so many people willing to weigh in with helpful advice!

Rick
5.4.4 HT speakers: T Ref fronts/LFE 1, SuperCenter Ref, T1 surrounds/LFE 2, HTR 7000 top fronts, Invisa 525 top rears
Zone 2 speakers; 2 Invisa 525's
AVR: Marantz SR 7010
Amps: AT525NC 5 channel, Parasound 275 v.2 stereo
Cable/TiVo, OPPO BDP 105D, Bluesound Node 2i
47" Panasonic 3D smart tv
The following user(s) said Thank You: WayneWilmeth, anthem

Please Log in or Create an account to join the conversation.

  • anthem's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 3920
    • Thank you received: 8076
    • Karma: 7
  • arrow_drop_downMore arrow_drop_upLess
anthem Posted 4 years 6 months ago
#9169
Hey rjohn: Dilettante's system is similar to mine; he has T1's, the Decware Torii MKlV, and Oppo 105 (not the 103, as listed above). He uses Venom 3's on the T1's (plugged directly in the wall) and Torii, but likes an Anti-Cable level 3 Reference power cable on the Oppo. He's tried the Venom 3 on his Oppo but doesn't like the sound. We both use the same interconnects and speaker cables. I'm running T2's, the Torii MKlV, Primaluna Premium Preamp, and Oppo 105 ; I use Venom 3's on everything, I love how my system sounds, and at this point, I have NO desire to change anything. I've tried an Decware DHC -1 silver power cord on my Oppo, sounds real good, but to my ears sounds better with the V3's. I plug the T2's into an Emotiva CMX -6 > CMX - 2...Dilettante has tried plugging the T1's into an CMX -6, but doesn't like the sound. He has often asked me why we are hearing differently with very similar systems, is it my Primaluna Premium Preamp? I don't know.

All this being said, try one on your amp/receiver first, then experiment with your cd player...a pair on your T2's for sure. If you don't like what you hear, send them back, 60 money back guarantee...I'm keeping mine.
D-Sonic m3a-600m Mono > Decware Zen Torii mk4 > McIntosh MC152 > Emotiva xpa1 Mono's > Anthem Statement P2 > Primaluna ProLogue Premium Preamp > Morrow Audio > Oppo 205 > Decware ZLC > Triton Reference

Every great performance deserves an Audience!
The following user(s) said Thank You: WayneWilmeth, rjohn79395, T Cobe

Please Log in or Create an account to join the conversation.

  • Dilettante's Avatar Offline
  • Junior Boarder
  • Junior Boarder
  • ALL things work together for good...
    • Posts: 33
    • Thank you received: 94
  • arrow_drop_downMore arrow_drop_upLess
Dilettante Posted 4 years 6 months ago
#9172
Ditto Anthem!
OPPO 105 - Decware Torii MK IV - Triton Ones
The following user(s) said Thank You: WayneWilmeth, anthem, rjohn79395, T Cobe

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back