arrow_downward
Moderator's Avatar
Hello all, Just recently I started getting a very low pitched flutter or rotor sound coming from the sub in one of my T1’s. That’s weird, but...
Moderator's Avatar
It is less than 48 hrs since I got a pair of Triton 2s and Supersat 60c. I hear a low volume constant hissing noise emanating from only one of the...
lsgarth's Avatar
Hello, I have a set of T1's in my HT, on occasion the right front speaker will make a loud pop then I can see the blue light start to blink on that...
ArthurDaniels's Avatar
Hi Gang, I have encountered a weird problem. While playing a recording from my computer (Lossless FLAC file) at a reasonably loud volume setting, I...
Moderator's Avatar
Hello there. So after taking a christmas break I re-opened the mastering room today, plugged in switched on my Triton 2`s and I am getting no bass...
mondaraguila's Avatar
I don't know where to put this thread, the MD can move it if he wishes. We all love music and hearing our lovely music through our favorite speakers....
RS1506's Avatar
Hello GE community! It's been a long time since I posted as I have been enjoying my T1's in my reference system since 2015. However, as a result of...
olymbos's Avatar
I have the exactly same problem with my left speaker what is the solution that you find? My right speaker the dial as 10 clock the left is at max and...
Moderator's Avatar
I securely shipped a pair of Triton Ones to a friend via FedEx Ground using original Goldenear boxes and packaging. While the outside cardboard and...
ArthurDaniels's Avatar
Everyone, Here is an update on Sheryl's Surgery: Surgery was on June 29 at Duke University Medical. The surgery was completely successful and...
WayneWilmeth's Avatar
By now some of you might have heard about the Thai soccer coach (25) and his 12 member team (aged 11-16) who entered a cave 10 miles from our home 2...
Moderator's Avatar
Sorry if this is covered elsewhere (I looked but couldn't find it). The amp on my Triton 2 is not turning on. I unplug/plug it in while music is...
HTSME's Avatar
Moderator Dude, where did "Recent Topics" go? I fear I may be stuck here in Bro Anthem's thread riding the elevator up and down forever!!!!! Don't...
WayneWilmeth's Avatar
Hi guys, I recently hooked up my new T1s, they played nicely for 2 different listening sessions of aroubd 3-4 hours each. Then I thought the police...
HTSME's Avatar
HI GE Gang, Quite by accident, I have discovered and corrected a subtle problem with the balanced audio cable connections in my setup. Here are the...
Moderator's Avatar
Hello all, My sub is powered on, the fuse looks okay but is not working. I tried running ARC again on the Anthem hoping that might help with no...
Moderator's Avatar
Help!!! I keep getting emails on this topic. How do I unsubscribe? I don’t see anything at the top or bottom of the page. I’m going crazy with...
Moderator's Avatar
Hi, Yesterday while watching a movie, suddenly there was a pop from the left Triton One speaker and the blue light started blinking as if the...
ArthurDaniels's Avatar
Just had a "burp" with the amp on one of my 3 year old T1's. Static that wouldn't go away. The fix was so simple!!! Both Goldenear (Moderator Dude...
WayneWilmeth's Avatar
I have been pretty happy with my Triton Twos since I bought them a little over two years ago. Today, the right-side tower started making a constant...
arrow_upward
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Advanced Topics Problems and Solutions