file Green light doesn't come on.

  • WayneWilmeth's Avatar Offline
  • Platinum Member
  • Platinum Member
    • Posts: 4581
    • Thank you received: 7022
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 4 years 9 months ago
#16738
Thanks Guys,
I am thankful to have every confidence in GEt to get this fixed.
I am in contact with my Distributor and he advised that the module might be playing when the light is off.
I have not been able to play anything where I can FEEL the passive radiator moving. Honestly, I can't say for sure I have been able to be SURE it was moving on the one that is working. Without taking off the sock that is, which I do NOT want to do.
He also advised to check the fuse. HOW??? How to open the cover????
I got down there (was not sure I was gonna get back up again!!!) with a phillips screwdriver but did not find any way to open it.
Pls advise. I even tried to take a pic (after looking online and in the manual for pics I did not find) so I could lift up my phone and see what it looks like, but it is too dark.
God Bless,
Wayne
God bless the child that's got his own.
The following user(s) said Thank You: T Cobe

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Member
  • Platinum Member
    • Posts: 4581
    • Thank you received: 7022
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 4 years 9 months ago
#16739
P.S. my speakers are 240 VAC in case that makes any difference.
God bless the child that's got his own.
The following user(s) said Thank You: T Cobe

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Member
  • Platinum Member
    • Posts: 4581
    • Thank you received: 7022
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 4 years 9 months ago
#16741
OK, the good wife got a pic down there and I was able to open the fuse holder with a smaller (-) screwdriver. The fuse is fine.
I also got the idea to crank the sub volume control all the way up on both speakers. Then I was able to detect air movement from the passive woofer on the working (light on) speaker, but nothing on the non working one.
Got the model number and am contacting my distributor with this new info now.
Thanks,
God bless,
Wayne
God bless the child that's got his own.
The following user(s) said Thank You: T Cobe

Please Log in or Create an account to join the conversation.

  • ArthurDaniels's Avatar Offline
  • Platinum Member
  • Platinum Member
    • Posts: 914
    • Thank you received: 1809
    • Karma: 1
  • arrow_drop_downMore arrow_drop_upLess
ArthurDaniels Posted 4 years 9 months ago
#16745
Hi Wayne,

Everything you have said appears to indicate that the amplifier or the power supply has failed in one of your Triton units. There is a simple way to confirm that the unit is not working.

!. Disconnect the speaker cables from the suspect Triton, but leave the LFE cable connected.

2. Disconnect both the speaker and LFE cables from the other Triton in the pair.

3. Temporarily disable or turn off any other sources of bass sounds

4.. Play something with pronounced bass which you are sure has an LFE component - in other words, be sure that your amplifier is sending a low frequency signal to the sub-woofer output so that it appears at the speaker LFE input.

You either will or will not hear bass coming from the suspect Triton's sub section.

Best,

Art
The following user(s) said Thank You: WayneWilmeth, T Cobe

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Member
  • Platinum Member
    • Posts: 4581
    • Thank you received: 7022
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 4 years 9 months ago
#16769
Well, I have had my hand up inside her private areas (Triton Two) and I can tell you boys she is well put together!!!!!
I have taken out the non working module and am waiting for the new replacement to come.
Pray I will be able to get it all back together correctly and working.
The job is not that hard, neither is it that easy.
But I am hopeful.
Will report more,
God Bless,
Wayne
God bless the child that's got his own.
The following user(s) said Thank You: rjohn79395

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 3115
    • Thank you received: 3374
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 4 years 9 months ago
#16771
Two parts. Would you like us to email you instructions?

Sorry for the trouble Wayne, but you'll be fixed up in no time.
The following user(s) said Thank You: WayneWilmeth, rjohn79395

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Advanced Topics Problems and Solutions Green light doesn't come on.