file No Bass Output on Triton Two

  • SVoidloss's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 9
    • Thank you received: 22
  • arrow_drop_downMore arrow_drop_upLess
SVoidloss Posted 1 year 8 months ago
#21867
Hello there.

So after taking a christmas break I re-opened the mastering room today, plugged in switched on my Triton 2`s and I am getting no bass one one unit.

I swapped leads, checked fuses etc to make sure it was nothing to do with anything else coming in to the speakers.
Nothing, no bass, only mids and tops.

Then when deciding to try the LFE input, I also got nothing, but when plugging in whilst everything was on (just to check earthing) when the LEF is not fulling plugged in to the socket, I get a bass tone. So the bass amp is working. When the lead is properly in, again, nothing.

The lead is also fine.

So it appears the bass amp is working, but for some reason no bass signal is getting routed to it, only the mids and highs.

I`m guessing I need to contact my dealer for new parts, just wondered if everything is just one module that needs changing??
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 4581
    • Thank you received: 7020
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 1 year 8 months ago
#21877
Sorry SVoidloss, I could not follow all that exactly.
VERY sorry you are having problems though.
You must have tried, but I did not catch that you did, did you swap speakers? Or swap wires from one speaker to the other one?
Seems like the problem might be in your receiver, not the speaker. Or not? Did you rule that out?
Please let us know more, or get it to your dealer for service. GEt service is exceptionally good.
God Bless,
Wayne
God bless the child that's got his own.

Please Log in or Create an account to join the conversation.

  • SVoidloss's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 9
    • Thank you received: 22
  • arrow_drop_downMore arrow_drop_upLess
SVoidloss Posted 1 year 8 months ago
#21878
It`s definitely the speakers. I have swapped everything at all stages of the signal path. It`s the same speaker every time.
Weirdly after leaving everything for an hour and trying once more in hope, the bass amp kicked in.
Could it have gone in to protect?
I`m a little worried this might happen again and the bass unit is failing.
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 2795
    • Thank you received: 3184
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 year 8 months ago
#21931
Odd failure ... bass amp input is the speaker terminals and RCA jack. Contact your dealer with the serial number and the problem (sounds like "light on/no output") and they will get the two electronics modules for that speaker replaced for you (we always replace both as a set).
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

  • SVoidloss's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 9
    • Thank you received: 22
  • arrow_drop_downMore arrow_drop_upLess
SVoidloss Posted 1 year 8 months ago
#21935
If I get them to send me the parts would it be possible to replace them myself?
The dealer is up in Glasgow scotland and I am down in london so it would be easier to send the parts to me than boxing up my T2 and shipping it up to Glasgow.
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 2795
    • Thank you received: 3184
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 year 8 months ago
#21936
Up to the distributor how they would handle, but certainly you can, all you need is a screwdriver. Basic instructions are available from This email address is being protected from spambots. You need JavaScript enabled to view it. for removal and replacement of the two modules.
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Advanced Topics Problems and Solutions No Bass Output on Triton Two