file Triton One - No Blue light on left tower and looks like no power to the SUB

  • Gopinathan's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 11
    • Thank you received: 11
  • arrow_drop_downMore arrow_drop_upLess
Gopinathan Posted 1 year 4 months ago
Last edit: 1 year 4 months ago by Gopinathan. info_outline
#22534
Hi,

Yesterday while watching a movie, suddenly there was a pop from the left Triton One speaker and the blue light started blinking as if the electricity supply was disconnect and reconnected. Happened again after 30 min which is when I switched everything off.

Today morning, tried starting the speaker, the blue light is not coming on and looks like there is no supply to the speaker. The speaker work on the App but minus the powered woofer.

Purchased this in Feb 2016. Although Goldenear warranty is for 3 years, In India the dealer provides warranty for a year only.

Needed to know what needs to be done to get this fixed. Is there a way to get this fixed at my place rather than carry the speaker to the dealers place. Dealer place is 175 KM drive from my house. Was purchased from AudioVision India, Mumbai.

Thanks
Girish Gopinathan
+917020824469
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 4581
    • Thank you received: 7020
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 1 year 4 months ago
#22536
Good luck Girish!!! Have you called AudioVison? They might have some solution for you.
I would not bet on it, having visited their showrooms a time or two. But I think you should give them a chance.
I hope it will all work out well, cheaply and soon for you!!!
God Bless,
Wayne
God bless the child that's got his own.
The following user(s) said Thank You: HTSME

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 2750
    • Thank you received: 3165
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 year 4 months ago
#22540
If the Blue light does not come on and start blinking when you plug it in (make sure to push the power cord in tightly and make sure the outlet is in fact live) you will need to have the electronics replaced in that speaker. Your dealer and/or the distributor should be able to order parts and make them available for in home service (only a screwdriver is required), just contact them with the description of the problem and the unit's serial number.
The following user(s) said Thank You: WayneWilmeth, HTSME

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Advanced Topics Problems and Solutions Triton One - No Blue light on left tower and looks like no power to the SUB