file A Possible and Subtle Issue With Balanced Audio Cable Connections

  • ArthurDaniels's Avatar Offline school
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 856
    • Thank you received: 1757
    • Karma: 1
  • arrow_drop_downMore arrow_drop_upLess
ArthurDaniels Posted 1 year 5 months ago
#23890
Hi Wayne,

Thanks for the tip regarding the cleaner.

Art
The following user(s) said Thank You: WayneWilmeth, HTSME

Please Log in or Create an account to join the conversation.

  • HTSME's Avatar Offline
  • Expert Boarder
  • Expert Boarder
    • Posts: 159
    • Thank you received: 286
  • arrow_drop_downMore arrow_drop_upLess
HTSME Posted 1 year 5 months ago
#23966

WayneWilmeth wrote: Bro Art and Bro Charlie,
This is the stuff.






I bought a (not cheap) extension cable for my headphones from Audioquest, came from the Amazon. When I got it home it would not work, not at all, zip, Zero sound, nada. A little squirt of this inside the female socket where I could not see but must have been all oxidized, and magic, got sound.

Cleanliness is next to..........well, can make the difference.
Happy listening,
God Bless,
Wayne


Wayne is right about this product. I used it years ago and it really works.

Del
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Advanced Topics Problems and Solutions A Possible and Subtle Issue With Balanced Audio Cable Connections