exclamation-circle Blinking Blue light when powering on

  • Wlingerfel001's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 2
    • Thank you received: 4
  • arrow_drop_downMore arrow_drop_upLess
Wlingerfel001 Posted 1 year 5 months ago
#23956
Hi guys,

I recently hooked up my new T1s, they played nicely for 2 different listening sessions of aroubd 3-4 hours each. Then I thought the police showed up in my theater. All of a sudden, sound off and blinking blue lights on both speakers.

Where is the fuse? I live in Thailand and grounding is a common issue, maybe a ground issue?

Best
Brent
The following user(s) said Thank You: WayneWilmeth, HTSME

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 4581
    • Thank you received: 7020
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 1 year 5 months ago
#23957
Hey Brent. welcome to the Monkey House.
Glad to have you here.
I live in Thailand too, WAY up North, the most North you can live in fact. Can see Burma from my house.

How are the speakers now? Should be playing and hitting on all cylinders again.
Are they?
We get short "fai dap", power outages here all the time, sometimes not so short, so the speakers probably went off and then powered back up (I HOPE) and the blinking should stop and they should play fine.
IF NOT, what is the situation now? Do you run them on a power conditioner or any other kind of surge/drop protection?
The TOnes do not have accessible fuses, if I am told correctly. I have TOnes and they are fantastic!!!!
IF you need any help, I can get you help from GEt here in Thailand very quickly.
Please let me know. We are all in this together.
God Bless,
Wayne
God bless the child that's got his own.
Attachments:
The following user(s) said Thank You: HTSME, Wlingerfel001

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 2833
    • Thank you received: 3208
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 year 5 months ago
#23960

Wlingerfel001 wrote: I recently hooked up my new T1s, they played nicely for 2 different listening sessions of around 3-4 hours each. Then I thought the police showed up in my theater. All of a sudden, sound off and blinking blue lights on both speakers.

Where is the fuse? I live in Thailand and grounding is a common issue, maybe a ground issue?


Wayne is correct. No accessible fuse and if the LED is blinking the fuse is good (its a powerline fuse).

Wayne is also correct about the cause, a power interruption can trigger a turn on cycle loop if the power goes on and off just right. Once the power is back on, unplug the power cords from both speakers and allow the power supply to fully discharge (maybe 1-2 minutes at most). Then plug the power cords back in and the speakers should go through their turn on cycle (blinking for about 30 seconds and then solid LED if the speaker is being played) and work fine.
The following user(s) said Thank You: WayneWilmeth, HTSME, Wlingerfel001

Please Log in or Create an account to join the conversation.

  • Wlingerfel001's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 2
    • Thank you received: 4
  • arrow_drop_downMore arrow_drop_upLess
Wlingerfel001 Posted 1 year 5 months ago
Last edit: 1 year 5 months ago by Wlingerfel001. info_outline
#23964
Gents, Thanks for the messages, it seems after my move some of my cables were mixed up. See the photo below, all look the same but it seems they are indeed not. I will check later today.
Attachments:
The following user(s) said Thank You: WayneWilmeth, HTSME

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 4581
    • Thank you received: 7020
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 1 year 5 months ago
#23975
Please let us know Brent if you are OK, back up and running, OR if you need some help?
Hope it is sorted, and happy listening,
God Bless,
Wayne
God bless the child that's got his own.
The following user(s) said Thank You: HTSME

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Advanced Topics Problems and Solutions Blinking Blue light when powering on