file Triton 2 Amp not turning on

  • byucatch22's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 1
    • Thank you received: 1
  • arrow_drop_downMore arrow_drop_upLess
byucatch22 Posted 1 year 1 week ago
#24320
Sorry if this is covered elsewhere (I looked but couldn't find it). The amp on my Triton 2 is not turning on. I unplug/plug it in while music is playing, the light blinks during the warmup then goes off and the amp remains off. Receiver setting is set to Large. The other speaker turns on as it should. Is it the fuse?

Note: this speaker has always occasionally 'popped' randomly without the receiver on - as if the current would bounce around and occasionally switch the amp on.

Much appreciation!
John
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 2748
    • Thank you received: 3161
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 year 1 week ago
#24323
Light blinking = fuse OK

Contact your dealer with the speaker's serial number and a description of the problem and they can get the warranty service process going for you.
The following user(s) said Thank You: WayneWilmeth

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Advanced Topics Problems and Solutions Triton 2 Amp not turning on