file Triton 2 plus are here and working on setup?

  • Monroe's Avatar Offline school
  • New Member
  • New Member
    • Posts: 8
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
Monroe Posted 4 months 4 weeks ago
#30613
I finally got to listen to my new Triton 2 plus last night. They are begging me to turn them up! I was using old
Paradigm 5se MK1 paired with Eclipse 12 aluminum cone dvc 12" sub (TC sounds) in a parts express sealed box powered by a Crown xls 1500 and Art Box Pro, old Carver amp all fed through a B and K Reference 20. Speakers sound good for what they are. Now just using the Tritons, Carver amp and B and K. I feel like I'm not getting the bass I should be getting. I'm hearing so much more of the music and details I didn't know existed, but maybe I'm missing something? Speakers only plugged in from amp, no LFE and set to Large in pre amp with Sub turned off. Suggestions?

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 3209
    • Thank you received: 3403
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 4 months 4 weeks ago
#30617
Hi Monroe, I would recommend connecting the two subwoofer outputs on your B&K Reference 20 preamp/processor to the LFE inputs on both of your towers. With this configuration, I would set your processor to large front speakers - and subwoofer to "on" or "yes". The Triton Two+ towers are designed to combine or sum together any bass they receive from the speaker wires with any bass they receiver from their LFE inputs. (I'd also suggest setting the B&K's sub out crossover to 80hz.) This configuration should work quite well. Happy Listening!

Please Log in or Create an account to join the conversation.

  • Monroe's Avatar Offline school
  • New Member
  • New Member
    • Posts: 8
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
Monroe Posted 4 months 4 weeks ago
#30619
Thank you for the suggestion. Was able to find a 'Direct' setting in the B and K that disables all crossovers and processing from the pre amp. Now I have and actually turned sub knobs back to 12 o'clock. Sound much better that way. I'll try the LFE connections next.

Please Log in or Create an account to join the conversation.

  • nate451's Avatar Offline
  • New Member
  • New Member
    • Posts: 18
    • Thank you received: 18
  • arrow_drop_downMore arrow_drop_upLess
nate451 Posted 4 months 1 week ago
#30683
Yeah, what the moderator said.

I have my 2+'s connected to an NAD M10V2 and they hit hard and fast.

Because of the way the M10 works, I have them connected to with 2 subs checked and the crossover to 40hz.
Main: 7.2.4
Triton One.R's
SuperCenter Reference
Invisa 650's
SuperSat3"s
SuperSat3c's
Anthem MRX 1140

Easy listening
Triton 2Plus's
NAD M10V2

Please Log in or Create an account to join the conversation.

  • Monroe's Avatar Offline school
  • New Member
  • New Member
    • Posts: 8
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
Monroe Posted 1 month 6 days ago
#30943
Had some time at work and educated myself on how the LFE or .1 channel works. For movies, leave processor set to surround and for music set processor to direct. Movie explosions are crazy now. Music still sounds amazing in it's respective mode. Speakers are now set between 11 and 12 at all times. Wife flew away for a work trip and I got to play with my stereo. Good deal.

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Clubhouse Show Off Your GoldenEar System Triton 2 plus are here and working on setup?