exclamation-circle Triton 3+ volume up but lose something

  • stixbnr32's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 8
    • Thank you received: 16
  • arrow_drop_downMore arrow_drop_upLess
stixbnr32 Posted 2 years 3 months ago
#24376
I am now trailing some Triton 3+ and the LFE is brilliant in movies which really surprised me.

But on the Marantz between -25db to -10db I find they sound fantastic with music. But up to 0DB where I can play my current Klipsch I think they lose something. Maybe the subs cannot keep up or is it because there is only one mid/bass driver?

I have turned off Audyssey as it says in the manual. I have trimmed the subwoofers out to -11db and then turn the gain to 1 oclock and that helped.

I am going to be swapping them around with the Klipsch and compare tonight too see if its worth the upgrade.

Any tips of tuning the Marantz with them that be great.
The following user(s) said Thank You: WayneWilmeth, rjohn79395

Please Log in or Create an account to join the conversation.

  • stixbnr32's Avatar Offline school
  • Fresh Boarder
  • Fresh Boarder
    • Posts: 8
    • Thank you received: 16
  • arrow_drop_downMore arrow_drop_upLess
stixbnr32 Posted 2 years 3 months ago
#24382
I figured it out so thought I would share here.

In 2 chan listening the speakers we set to Small LFE and not Large LFE like it says in the manual.

Made a lot of difference and they now walk over my old Klipsch RP serious for quality. Just not as loud as they are less efficient.

Love them. Time to sell and tradeup.
The following user(s) said Thank You: Moderator, WayneWilmeth, rjohn79395

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Support Triton Series Triton Towers Triton 3+ volume up but lose something