file Subwoofer Cable won't fit on LFE input

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 3168
    • Thank you received: 3388
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 week 6 days ago
#30546
Hi PENNSTATEMIKE, it sounds like the RCA jack/LFE connector used on this tower is out of spec. I would recommend contacting GoldenEar's customer service department at This email address is being protected from spambots. You need JavaScript enabled to view it. or 1-949-800-1805 (M-F 9 - 5:30 Eastern Time). They should be able to help you.

Please Log in or Create an account to join the conversation.

  • PENNSTATEMIKE's Avatar Offline
  • New Member
  • New Member
    • Posts: 6
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
PENNSTATEMIKE Posted 1 week 6 days ago
#30547
I've done that but never got a reply

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 3168
    • Thank you received: 3388
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 week 5 days ago
#30548
Hi PENNSTATEMIKE, I believe you've reached GoldenEar's customer service department - and they're helping you obtain a replacement amplifier for your Triton Two.

Please Log in or Create an account to join the conversation.

  • PENNSTATEMIKE's Avatar Offline
  • New Member
  • New Member
    • Posts: 6
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
PENNSTATEMIKE Posted 1 week 5 days ago
#30549
Yes, Chet Pelkowski is sending me a new subwoofer amplifier snd i will return the one that is on the speaker. Thanks.

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Support Triton Series Triton Towers Subwoofer Cable won't fit on LFE input