file Triton 2 Amp not turning on

  • arps00's Avatar Offline school
  • New Member
  • New Member
    • Posts: 2
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
arps00 Posted 1 month 5 days ago
#29782
Hi guys

I'm based in Sydney, Australia and own a pair of Triton 2 towers as my main left and right speakers in a 5.0 system. (the original Triton 2, not the 2+). Speakers were purchased in May 2013, so out of Warranty

One of the Triton 2 speaker's amp no longer turns on. The green light behind the speaker is off and the bass section is not producing any sound.

Troubleshooting steps I have tried:
1) Disconnected speaker from power for several days, no change
2) Swapped the fuses between the 2 speakers, the problem stayed with the same speaker
3) Swapped the power cords between the 2 speakers, the problem stayed with the same speaker

Could you please advise what I can do to get this fixed? If it involves dealing with a local dealer, another consideration is that the dealer I purchased from (Audio Connection in NSW Australia) no longer appears to be a Goldenear dealer as per their website - so in this case who should I get in touch with?

Thanks!
Arpan

Please Log in or Create an account to join the conversation.

  • Moderator's Avatar Offline
  • Moderator
  • Moderator
    • Posts: 3099
    • Thank you received: 3364
    • Karma: 19
  • arrow_drop_downMore arrow_drop_upLess
Moderator Posted 1 month 11 hours ago
#29798
Hi Arpan, It sounds like the amplifier built-into this Triton Two tower is defective and needs to be serviced. I would suggest contacting GoldenEar's service department at This email address is being protected from spambots. You need JavaScript enabled to view it.. They should be able to help you.

Please Log in or Create an account to join the conversation.

  • arps00's Avatar Offline school
  • New Member
  • New Member
    • Posts: 2
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
arps00 Posted 3 weeks 1 day ago
#29825
Thanks for your response. I've got in touch at This email address is being protected from spambots. You need JavaScript enabled to view it. and they are assisting me

Thanks again
Arpan

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Support Triton Series Triton Towers Triton 2 Amp not turning on