file Triton 2 Towers ( Not Triton 2 +) won't power on and no green light comes on sub

  • krishnakinfo's Avatar Offline school
  • New Member
  • New Member
    • Posts: 7
    • Thank you received: 0
  • arrow_drop_downMore arrow_drop_upLess
krishnakinfo Posted 1 month 3 weeks ago
#31045
Just got some used original Triton 2 ( not triton 2 +) from my cousin, Sounds great when set to small and used dual monolith subwoofers. When i try to use their built in subwoofers insert power cables nothing comes on and no subwoofer sound (tried to set the speakers to large and also tried small + lfe). on one towers green light comes on just once and gone when i plugged in the first time. just ordered some fuses will change them and see if that fixes the issue. What do you guys think? are the amps gone on the subs? i wanted to replace on my own where can i buy them?

Also can i just use them small and use external subs and never bothered to replace the amps? do i miss anything by doing so?

Please Log in or Create an account to join the conversation.

  • GDHAL's Avatar Offline
  • Platinum Member
  • Platinum Member
    • Posts: 608
    • Thank you received: 843
    • Karma: 1
  • arrow_drop_downMore arrow_drop_upLess
GDHAL Posted 1 month 3 weeks ago
Last edit: 1 month 3 weeks ago by GDHAL. info_outline
#31047
Golden Ear technical support is very good, and their warranty is rather generous. Why not try contacting GE?
Golden Ear Triton Reference (pair), Musical Fidelity M6si, Schiit Yggdrasil-OG-B, Oppo UDP-205, Emotiva ERC-3, LG OLED65C9PUA, Salamander Synergy Triple Unit SL20, Audeze LCD-X, GIK acoustic paneling
halr.x10.mx/TritonReference.htm ; halr.x10.mx/other.html
The following user(s) said Thank You: krishnakinfo

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back
You are here: Home Forum Support Triton Series Triton Towers Triton 2 Towers ( Not Triton 2 +) won't power on and no green light comes on sub