file 60c vs XXL

  • T Cobe's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 2294
    • Thank you received: 4367
    • Karma: 5
  • arrow_drop_downMore arrow_drop_upLess
T Cobe Posted 4 years 4 months ago
#9583
Steveo,

Glad to see the new cables arrived! Will they not fit if you push them straight into the end of the binding post? They look to have some sort of mechanism that will make them a snug fit. If they won't work striaght into the back of the post, you can try opening the post all the way and see if it will fit through the hole you would use to feed bare wire. If neither of those work, I'd call your dealer. Can't wait to hear your impressions on the new cables.

Cheers,

T Cobe
Speakers: Triton One L/R, SCXL, Aon 3 Surr/Back, HTR-7000 Height
Pre/Pro/AVR: Anthem AVM 60, Emotiva XSP-1
Amps: Emotiva XPA-5(2), Emotiva XPA-1L (2)
Sources: Oppo BDP-103D, Emotiva ERC-3, PS4, Pioneer PLX-1000 w/Ortofon 2M Bronze
Display: Epson 6030 UB, Elite Screens 110" Sable
The following user(s) said Thank You: WayneWilmeth, aribraun

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 4581
    • Thank you received: 7020
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 4 years 4 months ago
#9584
Hey Steveo,
Those look good.
The bananas that you have there should plug straight into the back of the binding posts, in the hole in the middle, they are spring loaded to be snug and you you can leave the binding posts tight.
As in this pic.
But some binding posts have a little plastic deal in there that does need to be removed before the bananas can go in. So if they really will not go, then unscrew the binding posts all the way, and take out that plastic bit. Also pictured I hope you can see it.
Hope this helps, God Bless,
Wayne
God bless the child that's got his own.
Attachments:
The following user(s) said Thank You: T Cobe, aribraun

Please Log in or Create an account to join the conversation.

  • anthem's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 3868
    • Thank you received: 7969
    • Karma: 7
  • arrow_drop_downMore arrow_drop_upLess
anthem Posted 4 years 4 months ago
Last edit: 4 years 4 months ago by anthem. info_outline
#9585
Sounds like an "the birds & the bee's" question. Male end (speaker cable) into female end (speaker). As T Cobe stated if that doesn't work try unscrewing the post and see if the banana plug will fit in the side hole.

Whew...all this male/female talk has me riled up. ;)
Decware Zen Torii mk4 > McIntosh MC152 > Emotiva xpa1 Mono's > Anthem Statement P2 > Primaluna ProLogue Premium Preamp > Morrow Audio > Oppo 205 > Decware ZLC > Triton Reference

Every great performance deserves an Audience!
Attachments:
The following user(s) said Thank You: WayneWilmeth, Splash51, T Cobe, aribraun

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 4581
    • Thank you received: 7020
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 4 years 4 months ago
#9586
Take a COLD shower Bro Anthem!!!!
Steveo, did you get it? If not, don't be afraid to say, I can find more pics.
The last set of interconnects I bought I could not even connect them, they kept falling off. AND I had paid more for these "special" connectors. I had to write the dealer in America, in total frustration and ask what I was doing wrong?????? I had never seen interconnects I could not use, I wanted to cut them off and trash them, he wrote back and just said "push them harder until they snap into place"!!!!! Now I love them, the best connectors I have!!!!!
ha ha
Have fun, it is all fun, AFTER it drives you mad!!!!!!
God Bless, Wayne
God bless the child that's got his own.
The following user(s) said Thank You: Splash51, T Cobe, aribraun

Please Log in or Create an account to join the conversation.

  • WayneWilmeth's Avatar Offline
  • Platinum Boarder
  • Platinum Boarder
    • Posts: 4581
    • Thank you received: 7020
    • Karma: 15
  • arrow_drop_downMore arrow_drop_upLess
WayneWilmeth Posted 4 years 4 months ago
#9587
Steveo,
They should plug straight in. BUT if they won't and if there is not a plastic deal to remove, then what the guys are saying is,
run out the binding post, unscrew it, and you will see a hole there where the bare wire can be attached, as in this pic.
You should be able to put the plug end of your cable through that hole and tighten down on it. I don't like to do it this way, but it can be the only way sometimes.
Let us know, God Bless,
Wayne
God bless the child that's got his own.
Attachments:
The following user(s) said Thank You: aribraun

Please Log in or Create an account to join the conversation.

  • Steveo's Avatar Offline school
  • Expert Boarder
  • Expert Boarder
    • Posts: 147
    • Thank you received: 282
  • arrow_drop_downMore arrow_drop_upLess
Steveo Posted 4 years 4 months ago
#9588
Hey guys. I have taken a photo at the back of my triton 1. There is definitely a black and red plug here stopping the plug from going in. They are in pretty tight. What's the best way to remove them?
Triton 1 Pair, Supercenter XXL, SS 3's
Digital-Nimitra Server>USPCB>Iso Regen>TX Ultra>chord dave>deqx hdp5
Analog-sp10mk2 Corian plinth, Ortofon Quintet Black , Michell Tecnoarm, PS Audio Nuwave Phono
Bel Canto REF600m L & R, Emotiva Xpa 5 Gen 2 for Center and rears
PS Audio P10
Attachments:
The following user(s) said Thank You: WayneWilmeth, Splash51, aribraun

Please Log in or Create an account to join the conversation.

Moderators: Moderator
menu
close
Menu
person_outline
arrow_back